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HiBeam Screen Builder

The HiBeam Screen Builder is the environment where you create screens, i.e., graphical user
interfaces consisting of pages with Java applets, from which you can monitor or run control
processes either from a local computer or a remote location, i.e., via a network or the Internet.
You link these screens with control projects created in the Workbench. An application operated
by the applet can consist of several screens linked together using hot link buttons.

You build screens using graphic objects arranged together in a document and linked to
Workbench variables. You can attach animation effects to these objects. Two types of graphic
objects in a document: static objects and animated objects. You can group objects to form a
single object then attach animations to the group. For example, you can animate a car, made up
of a group of objects, to move and its wheel objects to rotate. You can also reuse objects by
sending them to the library.

You view screens using a Java technology-enabled browser, i.e., Internet Explorer, Netscape
Navigator. 

You need to install one or more data servers to relay data between screens and running
resources. These data servers are installed separately. You port data servers for use on various
operating systems using the HiBeam Development Toolkit.

A web server provides access to the HTML pages making up your ScreenBuilder projects. You
can use any standard web server. You can also port a basic web server available with the
HiBeam Development Toolkit for use on an operating system where one is not available.
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Appearance
You can customize many aspects of the Screen Builder environment such as displaying
toolbars, a project browser, rulers, a status bar, and a grid. You can also choose to display the
output window.

title bar
menu bar
tool bars

project 
browser 
and 
workspace

output 
window
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Project Browser
The project browser enables you to navigate between all open projects and their individual
screens.

To display the project browser

1. From the Options menu, choose Toolbars.

2. In the Layout editor, check Projects Tree then click OK.

Rulers

You can choose to display rulers along the upper an left edge of the workspace. Rulers are
scaled according to the horizontal and vertical spacing of grid points.

To display rulers

1. From the Options menu, choose Toolbars.

2. In the Layout editor, check Rulers then click OK.
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Status Bar

The status bar, appearing at the bottom, displays different types of information:

! the current mouse position

! the size and position of objects selected in the workspace

To display the status bar

1. From the Options menu, choose Toolbars.

2. In the Layout editor, check Status Bar then click OK.

Grid

You can choose to display grid points in the workspace. You can specify the horizontal or
vertical spacing between grid points. You can also choose to enable the Snap to Grid option
making objects connect to the nearest point on the grid.

To display the grid

1. From the Options menu, choose Grid.

The Grid editor appears.

2. To change the horizontal or vertical spacing of the grid points, enter a value in the
respective field.

3. To have objects connect to the nearest grid point, check Snap to Grid.

4. Click OK.
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Output Window

The output window displays two types of information:

! messages from the document compiler

! results of the Find Variable and Cross References options

For the Find Variable and Cross references options, results in the output window consist of
three types of information:

! the name of the variable

! the type of animated graphic object attached to the variable

! the coordinates (in grid units) in the document 

To display the output window

" From the Window menu, choose Show Output Window.

To clear the contents of the output window

" From the Window menu, choose Clear Output Window.
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Menu Bar
You can execute some menu options using keyboard commands.

File New Ctrl+N creates a new document
Open Ctrl+O opens an existing document
Close closes the current document
Save Ctrl+S saves the current document
Save As saves the current document using 

another name
Save All saves all open documents
Exit leaves the Screen Builder

Edit Undo Ctrl+Z cancels the last action
Redo Ctrl+Y restores the last cancelled action
Cut Ctrl+X removes the selected item and places it 

on clipboard
Copy Ctrl+C takes a copy of the selected item and 

places it on the clipboard
Paste Ctrl+V inserts the contents of the clipboard 
Delete DEL removes the selected item from the 

selected item
Select All Ctrl+A selects all items in the active document
Edit Object
Properties Alt+Enter accesses the properties box for the 

selected object
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Edit (cont) Public Properties accesses the public properties box for 
the selected object. This option is only 
available for individual objects 
belonging to a group. 

Lock Properties locks the properties of the selected 
object. This option is only available for 
individual objects belonging to a 
group.

Project Settings accesses the Project window where 
you define the project settings

Compile compiles the current animated 
document

Send to Server accesses the Download-Send to Server 
editor

Tools Find Variable searches the current document for all 
occurrences of a variable and displays 
the results in the output window

Cross References searches the document for all variables 
and displays the results in the output 
window

Multiple Variable 
Selectors

accesses the Multiple Variable 
Selectors editor

Logbook Editor accesses the Logbook editor
Options Toolbars accesses the Layout editor where you 

specify whether to display toolbars, 
rulers, and a status bar

Static Parts enables the manipution of static parts
Animated Parts enables the manipulation of animated 

parts
Image Attributes accesses the Image Attributes editor 

where you can change the main 
settings of the graphic document
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Options 
(cont)

Grid accesses the Grid editor where you can 
change the appearance of the grid and 
specify whether items snap to the grid

Animation Effects enables the movement and rotation of 
items selected in the workspace

Display Objects IDs displays the identifiers assigned to 
objects. The same identifier appears in 
the title bar of the properties box for 
the object.

Layout Order enables the moving of selected objects 
to the back or to the front of others

Grouping enables the grouping, ungrouping, and 
regrouping of selected objects

Align enables the alignment of selected 
objects with the object the left, right, 
top, and bottom. The object located 
closest to the chosen direction serves 
as reference.

Library Open accesses the Library browser where 
objects are stored for reuse

Close closes the Library browser
Send to Library sends the selected object to the library. 

This option is only available when the 
library is opened.

Window Cascade sets the different views of the project 
to appear in a cascading manner

Tile sets the different views of the project 
to appear in a tiled manner

Show Output Window displays the output window below the 
workspace

Clear Output Window clears the contents of the output 
window
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Help Contents accesses the online help
Search Help On accesses the online help
About displays product and version 

information
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Toolbars
Screen Builder includes four toolbars from which you can perform various tasks:

! Main Toolbar

! Drawing Toolbar

! Animated Parts Toolbar

! Static Parts Toolbar

To display toolbars

1. From the Options menu, choose Toolbars.

The Layout editor appears.

2. Check the toolbars to display, then click OK.

The selected toolbars appear.

Main Toolbar

The main toolbar enables you to perform tasks also available as menu options.

creates a new document

opens an existing document

saves the current document

removes the selected item and places it on clipboard
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takes a copy of the selected item and places it on the 
clipboard

inserts the contents of the clipboard

cancels the last action

restores the last cancelled action

compiles the document

accesses the Download-Send to Server window 

accesses the Find Variable dialog box

searches the document for all variables and displays the 
results in the output window
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Drawing Toolbar

The drawing toolbar enables you to perform various operations on object selected in the
workspace.

brings the object to the front

sends the object to the back

groups the selected objects

ungroups the selected grouped object

accesses the properties editor for the selected object

switches the document to the background layout editing 
mode. Selecting both background and animated layout 
modes at the same time switches the document to the free 
editing mode.
switches the document to the animated layout editing 
mode. Selecting both animated and background layout 
modes at the same time switches the document to the free 
editing mode.
displays the grid in the workspace

aligns the left side of selected objects

aligns the right side of selected objects
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Animated Parts Toolbar

The Animated Parts toolbar enables you to insert various objects in the workspace.

aligns the top edge of selected objects

aligns the bottom edge of selected objects

inserts a text input object in the workspace

inserts a push button / text display object in the 
workspace

inserts a rectangle in the workspace

inserts a round rectangle in the workspace

inserts an ellipse in the workspace

inserts an image in the workspace

inserts a trend graph in the workspace

inserts a selection box in the workspace

inserts a rectangular slider (catch mouse position) in the 
workspace
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Static Parts Toolbar

inserts a basic operation in the workspace

inserts a pre-registered text in the workspace

inserts an email item in the workspace

inserts an arc in the workspace

inserts an elliptical slider in the workspace

inserts a polyline in the workspace

inserts a polygon in the workspace

inserts a line in the workspace

enables the selection and manipulation of existing 
objects. When activated, you cannot insert new objects in 
the document.
inserts an image in the background layout of an animated 
document
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Creating Animated Documents
ScreenBuilder projects are made up of one or more containers, i.e., HTML pages, each holding
one or more screens. These projects are stored in files having the .HAD extension. You link
ScreenBuilder projects to Workbench projects. The container displays its defined screens. You
can create links between screens belonging to the same container. When creating a container,
you need to specify the size of the screens it will hold. You can choose to apply a HTML
template to the container (HTML page). 

The screens are built with static and animated parts. These pages are made up of two graphic
layouts: a background picture and a dynamic image. You can switch between editing modes
where you can manipulate different parts of a screen.

A background picture is made up of static graphic parts. Whereas, a dynamic image is made
up of animated graphic parts. Animated parts are always displayed in front of the background
picture. 

You view screens in a Java technology-enabled browser by entering the IP address of the node
on which you downloaded the compiled document and its name (HTML). You can also create
a default screen that automatically opens when you enter only the IP address of a node. This
default screen must be called default.html. 

You can perform many management tasks for animated documents:

! Setting the Project Properties

! Switching Editing Modes

! Creating a Background

! Inserting Animated Objects

! Editing Objects

! Defining Animation Effects for Objects

! Selecting Variables

! Customizing the HTML Template
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! Using Multiple Variable Selectors

! Using the Graphic Objects Library

To create a ScreenBuilder project

1. From the File menu, choose New.

2. Type a name for the project and choose a location in which to store it.

The new project structure appears in the project browser holding one container (HTML
page) and one screen.

3. To add a container to the project:

a) In the project browser, select an existing container, then right-click.

b) From the contextual menu, choose New.

A new container structure appears in the browser holding one screen.

4. To add a screen to a container:

a) In the project browser, select an existing screen, then right-click.

b) From the contextual menu, choose New.

A new screen appears below the container.

5. Save changes to the project.
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Setting the Project Properties
When setting the properties of projects, you may need to perform the following tasks:

! Linking screens (animated documents) to Workbench projects

! Defining administrative and user passwords

! Defining data servers

! Modifying data server connections
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Linking a Project

You link animated documents to the Workbench project having the variable data to display.
You define three properties when linking projects:

! Type, the type of project. Possible types are ISaGRAF 3.X, ISaGRAF PRO, and
PLC import file.

! Path, the location of the project associated with the screen

! Extra files folder, the folder holding extra files, e.g., images, used by the animated
documents making up the Screen Builder project. Note: The names of files placed in the
Extra Files folder must not contain spaces, for example, an accetable name is my_file.gif.

When you change the project path, you need to update the connection information.

To link a project

1. From the Project menu, choose Settings.

2. In the Project window, select the Project tab.

3. Enter the required information in the fields, then click OK.
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Defining Passwords

You can choose to change the administrative and user password automatically set for HiBeam.
The administrative password is required to configure the data server when downloading a
Screenbuilder project. The user password is required to enable the connection between the Java
applet running on a screen and the data server in order to update the values of variables being
read and written. 

To change the Administrative password for all data servers

You change the Administrative password for all data servers associated with a screen project.
A screen project uses the same administrative password for all data servers.

1. From the Project menu, choose Settings.

2. In the Project window, select the Passwords tab.

Note: Before changing the administrative password, make sure to remember the original
password. When performing the next download, you will be prompted to provide the original
password.

3. In the Admin Password (Configure) field, enter the new password.

4. Click Update all Data Servers.
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To change the user password

1. From the Project menu, choose Settings.

2. In the Project window, select the Passwords tab.

3. In the User Password (Access Data) field, enter the new password.

4. Click Update all Data Servers.

5. In the animated document, create an input box into which the user can enter the new
password:

a) Insert a text input object.

b) In the object�s Properties window, select the Variables tab.

c) Set the Command (output) parameter to use the SYS_PASSWORD system variable.
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Defining Data Servers

You may need to modify the data server list to indicate the actual list of data server locations.
When you link a screen to a Workbench project, HiBeam identifies all IP addresses of
configurations connected to the ETCP network as data server locations. You need to remove
all IP addresses where no data server is installed to prevent errors when downloading. You also
need to add all IP addresses for data servers located on computers connected via a different
network, i.e., HSD. When a resource uses a data server located at a different IP address, you
may need to modify the resource�s data server connection. For details on modifying resource
data server conections, see page 22.

To add or remove a data server location

1. From the Project menu, choose Settings.

2. In the Project window, select the Data Servers tab.

3. To add a data server location, click Add, then in the IP Address Selection dialog, enter
the IP address of the data server and click OK. 

The IP address is added to the data server list.

4. To remove a data server location, select the data server from the list and click Remove.

The IP address is removed from the data server list.
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Modifying Data Server Connections

You may need to modify data server connections for resources using a data server located at a
different IP address. When you link a screen to a Workbench project, HiBeam automatically
identifies all resources defined in the Workbench project and sets them to use a data server
running on the same IP address as the configuration to which they are attached. Therefore,
when a resource needs to use a data server located at a different IP address, you need to
manually modify the connection to indicate the correct data server location. 

Note: You need to add data servers running on networks other than ETCP to the data server
list to make them available for use in a resource to data server connection. For details on adding
data servers, see page 21.

To modify a connection

1. From the Project menu, choose Settings.

2. In the Project window, select the Connections tab.
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3. Double-click the Data Server field of the resource connection to modify, then select a
data server location from the list of available ones.
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Switching Editing Modes
You can switch between one of three editing modes:

! Background layout, enables the manipulation of static parts of the document

! Animated layout, enables the manipulation of animated parts of the document

! Free, enables the manipulation of both static and animated parts of the document

In the background layout editing mode, the Animated Parts toolbar is unavailable. In this mode,
only static items can be selected and manipulated. You use this mode to prepare or update the
background layout without risking the modification of animated parts. 

In the animated layout editing mode, the Static Parts toolbar is unavailable. In this mode, items
of the static layout are visible but cannot be selected, manipulated, or changed. Animated items
can be selected and manipulated. You use this mode to build the animated layout over the
background picture with no risk of modification in static parts.

To switch to the background layout editing mode

" From the Options menu, choose Static Parts.

Or

" From the Drawing toolbar, click .

To switch to the animated layout editing mode

" From the Options menu, choose Animated Parts.

Or

" From the Drawing toolbar, click .
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To switch to the free editing mode

" From the Options menu, choose Static Parts and Animated Parts.

Or

" From the Drawing toolbar, click  and .
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Creating a Background
You can place images as static parts of a background layout. You create a background while in
either the background layout or free editing mode. The Static Parts toolbar holds all items
available for use in the background layout. The background layout editing mode displays only
items making up the background layout of the document.

To place an image in the background

1. From the Static toolbar, click .

In the workspace, the cursor appears as cross hairs.

2. In the workspace, place the cursor where you want the image frame to start.

3. Click and hold the mouse button.

4. Move the cursor to where you want the frame to end then release the mouse button.

An empty frame appears with the message No Image Loaded.

5. Double click anywhere inside the frame.

The properties editor appears.

6. In the editor, enter the required information.
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Inserting Animated Objects
You can insert many graphic objects as animated parts of the animated layout. You insert these
objects while in animated layout or free editing mode. The Animated Parts toolbar holds all
items available for use in the animated layout:

! Text Input

! Button

! Rectangle

! Round Rectangle

! Ellipse

! Image

! Trend Graph

! Selection Box

! Rectangular Slider

! Basic Operation

! Pre Registered Text

! Email

! Arc

! Elliptical Slider

! Polyline

! Polygon

! Line
HiBeam 1.21- Screen Builder 27



Text Input

The text input box consists of a text input field and a frame. The frame style can be shadowed.
The Frame Width is limited under the value that is the half of minus the font size from
minimum length of height or width of the boundary of the object. 

In the text input�s Properties window, you can define properties for Styles, Variables, Move,
and Aspect.

To insert a text input box

1. In the Animated Parts toolbar, click .

2. In the drawing area, position the cursor where you want to start the text input box.

3. Drag towards the opposite corner of the text input box.

Styles

Frame Style The style of shadow of the object. Possible values are Simple, 
Shadow, and Inverted Shadow.

Frame Width The width of the frame

Text The text strings displayed by the object. These strings only appear in 
the Screen Builder and not in the browser.

Font The font of the text strings. When a font is unavailable on the 
computer browsing a document, the computer�s default font is used.

Text Style The font style of the text strings. Possible styles are plain, bold, and 
italic.

Text Size The font size of the text strings. When a font size is unavailable on 
the computer browsing a document, the computer�s default font size 
is used.

Max Number of 
Digits 

The maximum number of digits or characters of input text that can be 
entered in the text input object. The minimum number of characters 
is one.
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Variables

Enable If the value of the variable linked to this item is true, then it is 
allowed to input text with keyboard after clicking on that object. 

Command When text has been entered in the object and the ENTER key is 
pressed, the corresponding value is sent to this variable.
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Button

The button object has a rectangular shape, text, and some animation on animated documents.
This text display consists of texts, a frame, and a fill part. The Frame Style can be shadowed,
and the rectangle may have a three-dimensional effect when used as a push button. The Frame
Width is limited under the value that is the half of minus the font size from minimum length of
height or width of the boundary of the object.

In the button�s Properties window, you can define properties for Styles, Variables, Move,
Aspect, and Action.

To insert a button

1. In the Animated Parts toolbar, click .

2. In the drawing area, position the cursor where you want to start the button.

3. Drag towards the opposite corner of the button.

Styles

Text The text strings displayed by the object. When Input text 
animation is active, the text strings can be changed according 
to the variable.

Font The font of the text strings. When a font is unavailable on the 
computer browsing a document, the computer�s default font is 
used.

Text Style The font style of the text strings. Possible styles are Plain, 
Bold, and Italic.

Text Size The font size of the text strings. When a font size is 
unavailable on the computer browsing a document, the 
computer�s default font size is used.

Horizontal text location The location on the horizontal plane of the text within the 
object rectangle. Possible values are Center, Left, and Right.
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Variables

Vertical text location The location on the vertical plane of the text within the object 
rectangle. Possible values are Center, Down, and Up.

Text Direction The direction of the text displaying. Possible directions are 
Horizontal and Vertical.

Frame Style The style of shadow of the object. Possible shadow styles are 
Simple, Shadow, and Inverted Shadow.

Frame Width The width of the frame

Button style The style of the frame when the box acts as a push button. 
Possible styles are 3D and flat.

Concat. text and value When set to TRUE, the displayed text is the concatenation of 
the Text property with the value of the Input.

Input text This animation makes the object display the value of a 
variable. Possible types of variable are BOOL, SINT, DINT, 
REAL, TIME, and STRING.
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Rectangle

A rectangle can represent, for example, pipes indicating a flow from one object to another with
a change of color or a container displaying a changing quantity of liquid as it flows to or from
another object. The rectangle consists of a frame and a fill part. When Frame Style is Shadow,
the object has shadow at its right-bottom side and when Frame Style is Inv.Shadow, it has the
shadow at its left-top side. Frame Width is limited under the value that is the half of minimum
length of height or width of the rectangle.

In the rectangle�s Properties window, you can define properties for Styles, Variables, Move,
Aspect, Action, Resize, and Rotate.

To insert a rectangle

1. In the Animated Parts toolbar, click .

2. In the drawing area, position the cursor where you want to start the rectangle.

3. Drag towards the opposite corner of the rectangle.

Styles

Frame Style The style of shadow of the object. Possible values are: Simple, 
Shadow, Inv. Shadow.

Frame Width The width of the frame.

Fill Back Color The back color of the inside part of the object when the Fill 
animation is active.

Fill Destination The direction of the Fill animation when the Fill animation is 
active. Possible values are UP, DOWN, LEFT, and RIGHT.

Var value (min fill) The minimum value of the variable linked to the Fill when the 
Fill animation is active.

Var value (max fill) The maximum value of the variable linked to the Fill when the 
Fill animation is active.
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Variables

Fill (input) This animation makes the object fill the inside part of the 
object by Fill Color.
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Round Rectangle

The round rectangle object is a rectangular shape having its corners rounded. This round
rectangle consists of a frame and a fill part. When Frame Style is Shadow, the object has
shadow on right-bottom side and when Frame Style is Inv.Shadow, it has the shadow on
left-top side. 

In the round rectangle�s Properties window, you can define properties for Styles, Move,
Aspect, Action, and Resize.

To insert a round rectangle

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the round rectangle.

3. Drag towards the opposite corner of the round rectangle.

Styles

Frame Style The style of shadow of the object. Possible values are Simple, Shadow, 
and Inv. Shadow.

Frame Width The width of the frame
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Ellipse

An ellipse can represent, for example, a container displaying a changing quantity of liquid as
it flows to or from another object.

In the ellipse�s Properties window, you can define properties for Styles, Move, Aspect, Action,
and Resize.

To insert an ellipse

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the bounding box of the
ellipse.

Note: The bounding box is the smallest rectangle in which the ellipse fits.

3. Drag towards the opposite corner of the bounding box of the ellipse.

Styles

Frame Style The style of shadow of the object. Possible values are Simple, Shadow, 
and Inv. Shadow.

Frame Width The width of the frame
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Image

The image object has a frame of rectangular shape and a fill part. The image object can hold
GIF, transparent GIF, animated GIF, and JPEG files. You cannot rotate image objects.

In the ellipse�s Properties window, you can define properties for Styles, Move, Aspect, Action,
and Resize.

To insert an image

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the image object.

3. Drag towards the opposite corner of the image object.

Styles

Image File The file name and the path of the image
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Trend Graph

The Trend Graph object displays the real-time values of Workbench variables in the form of
curves. This object consists of graph lines, plot points, a frame, a fill part, and a background.
You can choose to view real-time or historical values. For real-time values, you need to set the
value of the History Position parameter to 0. For historical values, you need to set Run to false
and set the value of the History Position parameter to a negative value. A trend graph chart can
display up to eight trends at the same time. 

In the trend graph�s Properties window, you can define properties for Styles, Variables, Move,
and Aspect.

To insert a trend graph

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the trend graph.

3. Drag towards the opposite corner of the trend graph.

Styles

Error color The color used to draw the part of the curve where an error 
occurred

Overlap multiple curve When set to TRUE, all curves use the same axis as 
reference. When set to FALSE, a separate area on the Y axis 
is reserved for each trend.

Display axis When set to TRUE, the X and Y axes are drawn on the trend 
graph

Refresh time The time interval between each redraw of the trends 
displayed in the trend graph object

Time display instances The number of time stamp instances displayed at the bottom 
of the Trend Graph object

Rec1..Rec8 � Variable The variable to trend. The Trend Graph Pro can display a 
maximum of eight trends.
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Variables

Rec1..Rec8 � Plot style The style of the plotted point in the graph. Possible styles 
are None, Circle, and Square. You define a style for each 
trend.

Rec1..Rec8 � Line color The color of the line representing the trend. You define a 
color for each trend.

Rec1..Rec8 � Display plot 
error 

The display action taken where an error occurs. Possible 
values are:
None, no special action
Display Line, use alternate color for line
Display Area, fill trend area with error color

Rec1..Rec8 � Min bound value The minimum value of the data for the trend. You define a 
minimum value for each trend.

Rec1..Rec8 � Max bound 
value

The maximum value of the data for the trend. You define a 
maximum value for each trend.

Note: The Min bound value and Max bound value properties must be the same for all trend 
instances from Rec1 to Rec8.

Time view range The range of time, in minutes, displayed in the trend graph

History position The time period, in minutes, of the trend values to display: 
current or historical. A value of 0 sets the current values to 
be displayed. A negative value sets historical values to be 
displayed.

Y-axis zoom Not yet implemented

Y-axis percent offset Not yet implemented

Rec1..Rec8 - Visible (input) The indication of whether the corresponding trend curve is 
visible. TRUE sets the trend curve to be visible.

Run (input) The indication of whether the values are updated in the trend 
graph. TRUE sets the display values to be updated. FALSE 
sets the trend graph to hold the current display values.
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Selection Box

The selection box object has the function of inputting a value into a variable. This object has a
rectangular shape, texts, and some animations on the animated documents. This selection box
consists of the selection texts and the selection area, list down button, the frame and the fill part.
The number of visible choices when the list is open, is Select Number. The index of the selected
item is output to the variable linked to Command, when the value of the variable linked to
Enable is true. 

In the selection box�s Properties window, you can define properties for Styles, Variables,
Move, and Aspect.

To insert a selection box

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the selection box.

3. Drag towards the opposite corner of the selection box.

Styles

Font The font of the text strings. If the PC browsing this system does not 
have this font, the font becomes the default "System" font.

Text Style The font style of the text strings. Possible styles are plain, bold, and 
italic.

Select Number The number of items that can be selected. The minimum value is 1.

Text0 .. Text9 The text strings displayed by the object to be selected.
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Variables

Enable This animation makes the object allow to output a value by a mouse click 
when the value of the variable linked to this item is true.

Command This animation makes the object output the value according to the selected 
item to the variable linked to this item after a mouse click.
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Rectangular Slider

The rectangular slider object reads the position of the cursor within its perimeter then sends a
value associated to the position to mapped variables. At run time, the slider is not visible. You
can define the accuracy of position readings by increasing or decreasing the number of
horizontal and vertical divisions within the slider. Typical uses of the slider object consist of
implementing scroll bars or linear potentiometers. 

In the rectangular slider�s Properties window, you can define properties for Styles, Variables,
Move, and Resize.

To insert a rectangular slider

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the rectangular slider.

3. Drag towards the opposite corner of the slider.

Styles

Action Style The mouse event triggering the reading of the cursor�s 
position

Left Limit Value The value associated to the left-most limit of the rectangle

Right Limit Value The value associated to the right-most limit of the rectangle

Number of Horizontal 
Divisions

The number of equal parts into which the X-axis of the slider 
is divided. The number of divisions directly affects the 
accuracy of readings of the cursor�s position. The minimum 
number of divisions is 1.

Bottom Limit Value The value associated to the lower limit of the rectangle
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Variables

Up Limit Value The value associated to the upper limit of the rectangle

Number of Vertical Divisions The number of equal parts into which the Y-axis of the slider 
is divided. The number of divisions directly affects the 
accuracy of readings of the cursor�s position. The minimum 
number of divisions is 1.

Horizontal Drag This variable is forced to the horizontal position pointed to by 
the mouse while dragging (when the mouse is pressed).

Horizontal Click This variable is forced to the horizontal position pointed to by 
the mouse when a selected event occurs.

Vertical Drag This variable is forced to the vertical position pointed to by 
the mouse while dragging (when the mouse is pressed).

Vertical Click This variable is forced to the vertical position pointed to by 
the mouse when a selected event occurs.

Enable This animation makes the object allow to output when the 
value of the variable linked to this item is true.
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Basic Operation

The basic operation object has only functions and no shape on the browser. This object
executes the operation with First Input and Second Input according to the Operation Kind
property when the value of the variable linked to Enable is set to true.

In the basic operation�s Properties window, you can define properties for Styles and Variables.

To insert a basic operation

1. In the Animated Parts toolbar, click .

2. In the drawing area, click where you want to place the basic operation.

Styles

Operation Kind The type of operation performed when the value of the variable linked 
to First Input or Second Input is changed.

Target page The target page to jump to, when the Operation kind is Other page 
(HAD) and the event occurs.

Target Web Page The Web page to jump to, when the Operation kind is Other WEB 
document (html...) and the event occurs.

Sig min value The minimum value of the generated signal. This value will be used 
when the corresponding Sig min value variable (same name) is not 
defined.

Sig max value The maximum value of the generated signal. This value will be used if 
the corresponding Sig max value variable is not defined.

Signal period The period of the generated signal. This value will be used if the 
corresponding Signal period variable is not defined.

Sampling period The sampling period of the generated signal. This value will be used if 
the corresponding Sampling period variable is not defined.
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Variables

First input This animation makes the object input the value as the first parameter 
for the operation according to the Operation Kind when the value of 
the variable linked to Enable is true.

Second input This animation makes the object input the value as the second 
parameter for the operation according to the Operation Kind when 
the value of the variable linked to Enable is true.

Command This animation makes the object output the result of the operation 
with First Input and Second Input according to the Operation 
Kind when the value of the variable linked to Enable is true.

Enable This animation makes the object allow to operate when the value of 
the variable linked to this item is true.

Operation statement This animation makes the object output the result of the operation 
itself. When this value is �1, operation result is overflow. If this value 
is �2, the result is a division by zero. According to the type of the 
variable linked to Command, the threshold of overflow is changed.

Sig min value 
(input)

This animation sets the minimum value of the generated signal. The 
corresponding Sig min value style is not used when the variable is 
connected.

Sig max value 
(input)

This animation sets the maximum value of the generated signal. The 
corresponding Sig max value style is not used when the variable is 
connected.

Signal period 
(input)

This animation sets the period of the generated signal. The 
corresponding Signal period style is not used when the variable is 
connected.

Sampling period 
(input)

This animation sets the sampling period of the generated signal. The 
corresponding Sampling period style is not used when the variable is 
connected.

Sinus Generated signal (if the variable is connected): sine wave signal.

Cosinus Generated signal (if the variable is connected): cosine wave signal.

Tangent Generated signal (if the variable is connected): tangent signal.
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Operation Kind

Ramp up Generated signal (if variable connected): ramp up signal. It is rising 
up to Sig max value, and when it reaches it, it changes to Sig min 
value.

Ramp down Generated signal (if variable connected): ramp down signal. It is 
rising down to Sig min value, and when it reaches it, it changes to 
Sig max value.

Triangle Generated signal (if variable connected): triangle signal.

Square Generated signal (if variable connected): square signal.

Random Generated signal (if variable connected): random value between Sig 
min value and Sig max value.

Execution time Generated signal (if variable connected): an integer equal to the 
execution time of the applet in milliseconds.

+, -, *, /, %, and, or, 
xor, nand, nor, nxor, 
<, <=, =, >, =>, !=

This parameter indicates the kind of operation when the value of the 
variable linked to First Input or Second Input is changed.

not This parameter indicates the kind of operation when the value of the 
variable linked to First Input is changed.

Go to back page Goes back to the previously displayed page in case of a multiple page 
document when the value of the variable linked to First Input is 
rising edge.

Go to forward page Goes to the following displayed page in case of a multiple page 
document when the value of the variable linked to First Input is 
rising edge.

Go to first page Goes to the first page of a multiple page document (home page) when 
the value of the variable linked to First Input is rising edge.
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Other page (HAD) Displays another page of a multiple page document when the value of 
the variable linked to First Input is rising edge. The target page is 
identified by the Target Page parameter, and identifies the pathname 
of another HAD document.

Other WEB 
document (html...) 

Jumps to another WEB page identified by another URL when the 
value of the variable linked to First Input is rising edge. The URL of 
the target page must be specified in the Target Web Page parameter.
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Pre Registered Text

The pre-registered text object has only functions and no shape on the Browser. This object
outputs the strings to the variable linked to Command according to the value of the variable
linked to the Input added the value of Offset value when the value of the variable linked to
Enable is true.

In the pre-registered text�s Properties window, you can define properties for Styles and
Variables.

To insert a pre-registered text

1. In the Animated Parts toolbar, click .

2. In the drawing area, click where you want to place the pre-registered text.

Styles

Variables

Text0 .. Text9 The text strings when the value of the variable linked to Enable is true.

Offset value The offset value that is added to the value of the variable linked to 
Input. For example, if the offset is 3 and value 1, the Text4 input is 
selected.

Input This animation makes the object input the value as the pointer to the 
text 0-9 when the value of the variable linked to Enable is true.
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Command This animation makes the object output the text that is pointed by the 
value of the variable linked to Input when the value of the variable 
linked to Enable is true.

Enable This animation makes the object allow to output when the value of the 
variable linked to this item is true.
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Email

The email object has only functionality and does not appear in the browser. This object sends
an email message to a specified email recipient. The email includes a return email address, a
subject line, and up to two lines of text in the body.

In the email�s Properties window, you can only define properties for Variables.

Note: Internet browsers, i.e., Internet Explorer, accessing screens having email objects must
set the Java permissions to enable unsigned content permissions across the network. For
information on setting the Java permissions of a browser, refer to the Using HiBeam Screens
application note, located in the documentation folder after installation.

To insert an email element

1. In the Animated Parts toolbar, click .

2. In the drawing area, click where you want to place the email element.

Variables

SMTP server The name or IP address of the mail server

Domain The domain name of the sender

Return address The complete email address of the message sender, for 
example, jsmith@company.com

Destination The complete email address of the message recipient

Subject The text appearing in the email message�s subject line

Text 1 The first line of text appearing in the email message�s body

Text 2 The second line of text appearing in the email message�s body

Send Sends the email message when the value switches from FALSE to TRUE

Ready The indication of whether the email object is ready to send. TRUE 
indicates that it is ready.
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Error The indication of whether the last email transmission was successful:
TRUE indicates that the email transmission was successful
FALSE indicates that the email transmission failed

Status Displays the status message for the last email transmission
50 HiBeam 1.21- Screen Builder



Arc

An arc is any unbroken part of the circumference of a circle. An arc can represent, for example,
a container displaying a changing quantity of liquid as it flows to or from another object. An
arc object is made up of a start angle and an arc angle:

You can convert an arc to a fan, i.e., an arc having a frame around its angle. A fan includes a
fill part.

In the arc�s Properties window, you can define properties for Styles, Variables, Move, Resize,
Aspect, and Action.

To insert an arc or a fan

1. In the Animated Parts toolbar, click .

2. In the workspace, draw a circle having its center at the same position as the center of the
arc.

The circumference of the circle appears red with the radius in black. The cursor appears
as cross hairs outside the circumference at the end of the radius.

3. Move the crosshairs along the circumference to where you want to set the start angle of
the arc then click.
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4. Move the crosshairs clockwise or counterclockwise to set the other end of the arc�s angle
then click.

The arc object appears in the workspace.

5. To insert a fan, double-click the arc object to access its Properties box, then in the Arc or
Fan field from the Styles tab, select Fan.

Styles 

Fan or Arc The drawing style of the object. Possible values are Arc and 
Fan.

Frame Style The style of shadow of the object. Possible values are Simple, 
Shadow, and Inverted Shadow.

Frame Width The width of the frame

Start Angle The start angle of the object

Arc Angle The arc angle of the object

Min Start Angle Limit The minimum start angle of the object

Max Start Angle Limit The maximum start angle of the object

Var Value (Min start) The minimum value of the variable linked to Start Angle 
(input) when Change Start Angle animation is active

Var Value (Max start) The maximum value of the variable linked to Start Angle 
(input) when Change Start Angle animation is active

Min Arc Angle Limit The minimum arc angle of the object

Max Arc Angle Limit The maximum arc angle of the object

Var Value (min angle) The minimum value of the variable linked to Arc Angle 
(input) when Change Arc Angle animation is active

Var Value (max angle) The maximum value of the variable linked to Arc Angle 
(input) when Change Arc Angle animation is active
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Variables

Start Angle (input) This variable changes the start angle of the object

Arc Angle (input) This variable changes the arc angle of the object
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Elliptical Slider

The elliptical slider object reads the position of the cursor within a circular area then sends a
value associated to the position to mapped variables. At run time, the slider is not visible.
Typical use of the slider object consist of implementing a potentiometer.

In the elliptical slider�s Properties window, you can define properties for Styles, Variables,
Move, and Resize.

To insert an elliptical slider

1. In the Animated Parts toolbar, click .

2. In the drawing area, position the cursor where you want to start the bounding box of the
elliptical slider then click.

Note: The bounding box is the smallest rectangle in which the elliptical slider fits.

3. Drag towards the opposite corner of the bounding box of the slider, then click.

Styles

Start Angle The start angle of the elliptical slider 

Arc Angle The arc angle of the object

Action Style The mouse event triggering the reading of the cursor�s position

Var Value (start angle) The minimum value of the variable linked to output Drag and 
Click variables

Var Value (start+arc angle) The maximum value of the variable linked to output Drag and 
Click variables
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Variables

Number of Divisions The number of equal parts into which the area of the slider is 
divided. The number of divisions directly affects the accuracy 
of readings of the cursor�s position. The minimum number of 
divisions is 1.

Ratio Inner Radius The circular area within the slider that is not active. This area 
starts at the center of the elliptical slider and is defined as a 
percentage of the radius.

Enable This animation makes the object allow to output when the 
value of the variable linked to this item is true.

Drag This variables is forced to the angle pointed to by the mouse 
while dragging (when the mouse is pressed).

Click This variables is forced to the angle pointed to by the mouse 
when a selected event occurs.
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Polyline

A polyline is made up of one or more connected lines that form an open figure. A polyline can
remain static or be used to display animation.

In the polyline�s Properties window, you can define properties for Styles, Move, Resize,
Rotate, Aspect, and Action.

To insert a polyline

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want the first line of the polyline to
begin then click.

3. Move the cursor in the direction of the line�s endpoint.

4. Click when the cursor reaches the line�s endpoint.

This position becomes the starting point of the next line.

5. Repeat steps 3 and 4 for every line of the polyline.

6. To end the polyline, double-click.

Styles

Line Style The style of the line. Possible values are Normal, Dash, and 
Dot.

Line Width The width of the line

Arrow Style The style of the arrow head used with the polyline object. 
Possible values are None, Filled, Thin, and Thin Filled.

Arrow Location The location of the arrow head. Possible values are End, 
Begin, and Both.
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Polygon

A polygon is made up of three or more connected straight lines that form a closed figure. Each
line is called a segment. A polygon can remain static or be used to display animation.

In the polyline�s Properties window, you can define properties for Styles, Move, Resize,
Rotate, Aspect, and Action.

To insert a polygon

1. In the Animated Parts toolbar, click .

2. In the workspace, position the cursor where you want to start the polygon then click.

3. Move the cursor in the direction of the line�s endpoint.

4. Click when the cursor reaches the line�s endpoint.

This position becomes the starting point of the next line.

5. Repeat steps 3 and 4 for every line of the polygon.

6. To end the polygon, double-click.

Styles

Var Value (min fill) The minimum value of the variable linked to the Fill when the 
Fill animation is active

Var Value (max fill) The maximum value of the variable linked to the Fill when 
the Fill animation is active.

Fill Back Color The background color of the inside part of the object when 
the Fill animation is active

Fill Destination The direction of the Fill animation when the Fill animation is 
active. Possible values are Up, Down, Left, and Right.
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Variables

Frame Style The style of shadow of the object. Possible values are Simple, 
Shadow, and Inverted Shadow.

Frame Width The width of the frame around the object

Fill (input) This variable is used to fill the inside part of the object by Fill 
Color.
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Line

You can insert three types of lines: normal, dashed, and dotted. You can also choose to have
arrowheads at either end or both ends. A line�s width cannot exceed the value that is half of
minimum length of height or width of the boundary of the object.

In the line�s Properties window, you can define properties for Styles, Move, Resize, Rotate,
and Aspect.

To insert a line

1. In the Animated Parts toolbar, click .

2. In the drawing area, position the cursor where you want to start the line then click.

3. Move the cursor in the direction of the line�s endpoint.

4. Click when the cursor reaches the line�s endpoint.

Styles

Line Style The style of the line. Possible values are Normal, Dash, and Dot.

Line Width The width of the line

Arrow Style The style of arrow head used with the line. Possible values are None, 
Filled, Thin, and Thin Filled.

Arrow Location The location of the arrow heads on the line. Possible values are End, 
Begin, and Both.
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Editing Objects
You can perform many editing tasks on objects:

! Selecting Objects

! Editing the Properties of Objects

! Cutting, Copying, and Pasting Objects

! Deleting Objects

! Moving Objects

! Resizing Objects

! Grouping Objects

! Aligning Objects

! Moving Objects to the Front and Back
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Selecting Objects

Selecting objects is required as a first step for all editing functions. When the "Selection"
button is depressed in the Static Parts toolbar, you cannot insert graphic objects in the
workspace; you can only select existing objects. You can choose to select one or more objects
at the same time.

The position and size of a selected object is displayed in the status bar.

To select a single object

1. In the Static Parts toolbar, click .

2. In the workspace, click the desired object.

To select multiple objects

You can select multiple objects either by selecting individual objects or by dragging the cursor
to enclose them. When dragging, an invisible rectangle shows the enclosed area.

1. In the Static Parts toolbar, click .

2. Do one of the following steps:

# Hold down the Shift key while clicking the desired objects one after the other.

# Position the cursor to the left and above the desired objects, then drag to enclose
them.
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Deselecting objects

" To deselect objects selected in the workspace, do one of the following:

# Click on an empty space in the workspace.

# Press the ESCAPE key.

In the object list, you can use the TAB and SHIFT+TAB keys to select the next or previous
objects.

When an object is selected, you can move it by dragging it with the mouse. You can adjust its
location using the arrow keys. 
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Editing the Properties of Objects

You can change the properties of objects. Two types of properties exist: static and dynamic.
For static properties, you enter a value or choose from the available options. You enter this
information in the Value fields. For dynamic properties, you select variables to which you bind
them. You enter this information in the Variable fields. The Origin field shows the type of the
selected variable. You can also define animation effects for objects. For details on defining
animation effects, see page 73.

To edit the properties of an object

1. Double-click the object.

The properties window for the object appears.

2. In each of the tabs, for the individual properties, enter the required information.

# For the static properties, enter a value or choose from the drop-down list of available
options.

# For the dynamic properties, select the variables.
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Cutting, Copying, and Pasting Objects

Once you select an object, you can choose to perform these operations using the icons in the
Main toolbar, the commands from the Edit menu, or the commands from a contextual menu.
To use the contextual menu, right-click a selected object.

To cut objects

1. Select the desired object.

2. Do one of the following:

# From the Main toolbar, click .

# From the contextual menu, choose Cut.

The object is removed from the workspace and a copy of it is placed on the clipboard.

To copy objects

1. Select the desired object.

2. Do one of the following:

# From the Main toolbar, click .

# From the contextual menu, choose Copy.

A copy of the object is placed on the clipboard.
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To paste objects

You can insert the contents of the clipboard into the workspace.

" In the workspace, click where you want to insert the object, then do one of the following:

# From the Main toolbar, click .

# From the contextual menu, choose Paste.

The contents of the clipboard is inserted in the workspace.
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Deleting Objects

Once you select an object, you can choose to delete it using the commands from the Edit menu,
or from the contextual menu. To use the contextual menu, right-click the selected object.

To delete objects

1. Select the desired object.

2. Do one of the following:

# From the Edit menu, choose Delete.

# From the contextual menu, choose Delete.

The object is removed from the workspace.
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Moving Objects

You can move objects within the workspace.

To move objects

" Select one or more objects then do one of the following:

# Drag the objects to their new position

# Press the arrow keys
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Resizing Objects

You can resize objects in the workspace. However, you need to select objects before resizing
them.

To resize an object

1. Select the desired object.

2. Click a handle (a small black square on the outer edge of the selected object) then move it
in the appropriate direction. 
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Grouping Objects

You can group individual objects in a document to form a unique object. You can also group
individual groups of objects. When objects are grouped, you cannot resize, move, delete, or
copy them individually. You can change the properties of individual objects belonging to a
group as well as those properties of grouped objects. When groups contain only static items,
they are considered part of the static layout. When groups contain one or more animated items,
they are considered part of the animated layout.

Groups can have some animation effects (move, resize, rotate...) other than those effects
attached to the grouped items. Groups can be selected for designing their animation area or
entering related animation variables in their property dialog box.

Once you select objects, you can choose to group and ungroup them using the commands from
the Layout menu or using the icons from the Drawing toolbar. You can also choose to regroup
ungrouped objects.

To group objects

1. Select the desired objects.

2. Do one of the following:

# From the Drawing toolbar, click .

# From the Layout menu, choose Grouping, then Group.

To ungroup objects

1. Select the desired grouped object.

2. Do one of the following:

# From the Drawing toolbar, click .

# From the Layout menu, choose Grouping, then Dissociate.
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To regroup objects

1. Select the desired ungrouped (dissociated) objects.

2. From the Layout menu, choose Grouping, then Regroup.
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Aligning Objects

You can align objects relative to their left side, right side, top edge, or bottom edge.

Once you select objects, you can choose to align them using the commands from the Layout
menu or using the icons from the Drawing toolbar:

To align and position objects

1. Select the desired objects.

2. Do one of the following:

# In the Drawing toolbar, click the desired icon.

# From the Layout menu, choose Align, then the desired direction.

aligns the left side of selected objects

aligns the right side of selected objects

aligns the top edge of selected objects

aligns the bottom edge of selected objects
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Moving Objects to the Front and Back

You can move objects to the front or to the back of each other. However, animated parts are
always displayed on the front.

Once you select objects, you can choose to move them using the commands from the Layout
menu or using the icons from the Drawing toolbar.

To bring an object to the front

1. Select the object.

2. Do one of the following:

# From the Drawing toolbar, click .

# From the Layout menu, choose Order, then Bring to Front.

To send an object to the back

1. Select the object.

2. Do one of the following:

# From the Drawing toolbar, click .

# From the Layout menu, choose Order, then Send to Back.
72 HiBeam 1.21- Screen Builder



Defining Animation Effects for Objects
You can define many animation effects for objects:

! Action

! Aspect

! Move

! Resize

! Rotate
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Action

Any object or group can act as a push button. The styles and variables of the "Action" tab allow
you to define a push button-like behavior of the object. Below are the styles and variables
grouped in the "Action" tab when editing the properties of an object.

The Action animation effects apply to the following objects: Arc, Line, Button, Rectangle,
Round Rectangle, Ellipse, Image, Polyline, and Polygon.

Styles

Action Style The mouse events that drive the action

Action Kind This parameter indicates the kind of action of the object 
when the event occurs. See the Possible Types of Action 
table below for possible values.

Pushed value This parameter indicates the value when the Action Kind is 
Pushed / released values and Action Style is Down.

Released value This parameter indicates the value when the Action Kind is 
Pushed / released values and Action Style is Up.

Target Screen This parameter indicates the Target Screen to jump to, when 
the Action Kind is Other Screen and the event occurs.

Target Web Page This parameter indicates the Web Page to jump to, when the 
Action Kind is Other WEB document and the event 
occurs.

Increment value Step used for increasing the value when action kind is Auto 
increment value.

Increment slow time Period used for first increment when action kind is Auto 
increment value.

Increment fast time Period used for repeating increment when action kind is 
Auto increment value.
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Possible Types of Action

Display highlight If this parameter is TRUE, the object is highlighted (with a 
special border) and mouse pointer changes when object is 
pointed to by the mouse.

Information Text to be displayed in the status bar when object is pointed 
to by the mouse.

Auto Increment value The value of the input variable (see description below) is 
increased whilst the button is pushed. The elapsed time 
before first increment is the value of increment slow time. 
After that, the increment is repeated with a period of 
increment fast time. After 20 steps, the increment value is 
multiplied by 5.

Go to previous screen Go back to the previously displayed screen in case of a 
multiple screen document. This action only becomes 
available after moving from the initial screen to another 
using an action such as Other screen.

Go to next screen Go to the next displayed screen in case of a multiple screen 
document. This action only becomes available after using 
the Go to previous screen action.

Go to first screen Go to the first screen of a multiple screen document (home 
page).

No action Button has no action.

Other screen Display another screen of a multiple screen document. The 
target screen is identified by the Target Screen parameter.

Other WEB document (html) Jumps to another WEB page identified by another URL. The 
URL of the target page must be specified in the Target Web 
Page parameter.

Pushed / released values Set the Command variable (see description below) to the 
value specified in Pushed value when the button is pressed, 
and to the value specified in released value when the button 
is released.
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Variables

Reverse input Force Command to the negation of the input variable.

Value input Force Command to the value of the input variable.

Enable The "Action" animation is enabled when the value of the 
variable linked to this item is true. 

Input Input value used for Value input or Reverse input actions.

Command The object updates the value of this variable on a mouse 
click when the Action Kind is Pushed / released values, 
Reverse input or Value input. 
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Aspect

The Aspect animation properties have Styles and Variables propeties. 

The Aspect animation effects apply to the following objects: Arc, Line, Text Input, Button,
Rectangle, Round Rectangle, Ellipse, Image, Selection Box, Selection Box, Polyline, and
Polygon.

Styles

Blink Kind The type of Blink when the object is blinking

Line Color The color of a line object

Fill Color The inside color of the object

Frame Color The color of frame of the object

Text Color The color of the text in the object

Shadow Color The color of the shadow when the frame style is not simple

Swap Line Color The color of the object when the animation of Change Color 
Line or Blink (change color) is active

Swap Fill Color The color of inside part of the object when the animation of 
Change Color Fill or Blink (change color) is active

Swap Frame Color The color of frame of the object when the animation of Change 
Color Frame or Blink (change color) is active

Swap Text Color The color of the text of the object when the animation of 
Change Color Text or Blink (change color) is active

Var value (line color) When the Change Color Line variable reaches this value, the 
Line Color style is applied. For greater values, the applied 
color is a mixing of the Line Color and the Swap Line Color, 
with a coloring depending on the value.

Var value (swap line color) When the Change Color Line variable reaches this value, the 
Swap Line Color style is applied. For lower values, the applied 
color is a mixing of the Line Color and the Swap Line Color, 
with a coloring depending on the value.

Var value (fill color) Same as Line Color except for filling the object
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Variables

Var value (swap fill color) Same as Swap Line Color, for filling the object

Var value (frame color) Same as Line Color, for the frame of the object

Var value (swap frame 
color) 

Same as Swap Line Color, for the frame of the object

Var value (text color) Same as Line Color, for the text inside the object

Var value (swap text color) Same as Swap Line Color, for the text inside the object

Visibility Sets the object to appear or disappear on the screen according 
to the real time boolean value of PLC data. When the value of 
the variable linked to Visible is true, the object appears, i.e., is 
visible. When the value is false, the object disappears from the 
screen, i.e., is invisible. Caution: When objects belong to a 
group, the visibility animation of individual objects depends on 
the visibility state of the group. When the group object is 
visible, the visibility animation of each object is effective. 
When the group object is invisible, the visibility animation of 
each object is not effective. 

Blink Sets the object to blink on the screen according to the real time 
boolean value of data. The Blink Kind style indicates the kind 
of blinking: Change Color Blink or Visible Blink. When the 
value of the variable linked to Blink is true, the object appears 
and disappears frequently with Visible Blink, or the object 
changes the color to the swap colors (for Line, Fill, Frame and 
Text colors) frequently. When the value is false, the object 
keeps its normal state.

Change Color Fill Sets the object to change the Fill Color to the color defined for 
Swap Fill Color

Change Color Frame Sets the object to change the Frame Color to the color defined 
for Swap Frame Color
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Change Color Text Sets the object to change the Text Color to the color defined 
for Swap Text Color

Change Color Line Sets the object to change the Line Color to the color defined 
for Swap Line Color
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Move

The Move animation effect indicates the movement, i.e., translation, of an object along the
X-axis and Y-axis according to the real time integer or float value of PLC data. Before setting
the Move effect properties, you need to define the area throughout which the object can move.
You define this area by dragging a red frame that surrounds the object, available when you
select Animation Effects from the Options menu:

The Move animation effects apply to the following objects: Arc, Elliptical Slider, Line, Text
Input, Button, Rectangle, Round Rectangle, Ellipse, Image, Selection Box, Selection Box,
Rectangular Slider, Polyline, and Polygon.

The properties for the Move animation effect are:

For the Horizontal move property, when the linked variable�s value is equal to Var value (left
limit), the object is at its original point. Whereas, when the linked variable�s value is equal to
Var value (right limit), the object is at the other end of the defined area. For the Vertical move
property, when the linked variable�s value is equal to Var value (bottom limit), the object is at
its original point (bottom of the defined area). Whereas, when the linked variable�s value is
equal to Var value (up limit), the object is at the top of the defined area.

Horizontal move The variable to which the translation along the X-axis is linked

Vertical move The variable to which the translation along the Y-axis is linked

Var value (left limit) The minimum value of the variable linked to Horizontal move

Var value (right limit) The maximum value of the variable linked to Vertical move

Var value (bottom limit) The minimum value of the variable linked to Horizontal move

Var value (up limit) The maximum value of the variable linked to Vertical move
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Resize

The resize animation effect indicates the resizing on the screen according to the real time
integer or float value of PLC data. With Horizontal resize, the object can resize along the
X-axis. The Horizontal resize resizes the object from Left limit ratio up to Right limit ratio.
When the value of the PLC variable is equal to Var value (left limit) the width of the object is
Left limit ratio % of the original size. Right limit ratio can be bigger than 100%. The same
applies to Vertical resize, with top and bottom limits.

The default implementation of the Resize effect resizes the object according to its bottom/left
corner. It means that the bottom / left point of the object is fixed. You can select another fixed
point by setting the Reverse horizontal resize effects and/or Reverse vertical resize effects
styles.

The Resize animation effects apply to the following objects: Arc, Elliptical Slider, Line,
Rectangle, Round Rectangle, Ellipse, Image, Rectangular Slider, Polyline, and Polygon.

Warning: You cannot use the Reverse horizontal resize effects and/or Reverse vertical resize
effects styles if a "Move" animation is defined for the object.

You can perform many combinations of resizing:

Fixed point Reverse Horizontal Reverse Vertical

A FALSE TRUE
B TRUE TRUE
C FALSE FALSE
C TRUE FALSE
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Rotate

The rotate animation effect indicates the rotation of an object, around its center of rotation
center, on the screen according to the real time integer or float value of PLC data. A positive
value rotates the element in a counterclockwise direction and a negative value, in a clockwise
direction. The rotation is performed around the the object�s center of rotation. You define the
center of rotation by dragging a blue dot appearing on the object, available when you select
Animation Effects from the Options menu. 

The Resize animation effects apply to the following objects: Line, Rectangle, Round
Rectangle, Ellipse, Image, Rectangular Slider, Polyline, and Polygon objects.

The properties for the Rotate animation effect are:

Rotation The variable to which the rotation effect is linked

Min angle limit The angle of rotation when the value of the variable linked to 
Rotation equals Var value (min angle limit)

Max angle limit The angle of rotation when the value of the variable linked to 
Rotation equals Var value (max angle limit) 

Var value (min angle limit) The minimum value of the variable linked to Rotation

Var value (max angle limit) The maximum value of the variable linked to Rotation
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If Var value (min angle limit) equals 0 and this value equals Min angle limit, then the object
is at its point of origin. If Var value (max angle limit) equals 90 and this value equals Max
angle limit, then the object rotates 90 degrees. When the value of Min angle limit is greater
than Max angle limit, the object can rotate clockwise if the value is increasing.

Note: When objects for which rotation does not apply belong to a group having rotation, these
objects follow the group�s behavior.
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Selecting Variables
The dynamic properties of objects use constants or variables to define their behavior at
runtime. You can choose variables from one of four origins:

! PLC Data

! Selectors, not yet documented

! Internal Variables

! System Variables

All possible origins for variables are listed in the browser on the left. For a selected origin, the
list box shows the available data for these variables:

! Name, identifier for the variable. It can be a system information provided by the generic
applet or by the embedded Data Server. The name can also be any constant value or
memory variable used internally in the document or the tag for PLC data. 

! Type of the variable. The possible types are DINT, SINT, REAL, TIME, and STRING.

! Scope of the variable. The possible values are Local or Global.

! Initial value of the variable
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When using a variable, typing the variable name directly in the edit field automatically
launches a search for the variable throughout all possible origins. If found, all variables
belonging to its origin appear in the list with the matching variable selected. If matches from
different origins are found, the origins appear bolded in the tree.

You can map variables of any data type to any parameter. The system ensures automatic data
type conversion in all cases. However, warning messages may appear during compilation if the
variable selection leads to a possible loss of accuracy.

To use a constant value

" In the Variable field for an object�s property, type the value.

To select a variable

1. In the Variable field for an object�s property, click .

The Variable window appears.

2. In the browser, at the left, select the origin of the variable.

The available variables for the selected origin appear in the list at the right.

3. From the list, select the desired variable, then click OK. 

The variable and its origin appear in the property�s Value and Origin fields.
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PLC Data

When the origin is a PLC, the "..." runs a PLC dependent box for browsing variables. The
example below shows the box used for ISaGRAF PRO resources, enabling the selection of
parts of complex data such as structures and arrays:
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Internal Variables

Internal variables are created and managed by the applet. They have no relationship with PLC
data. Internal variables are used to establish direct links between graphic objects of a screen.
For example, if you want a push button to act directly on the state of a LED display, you can
map an internal variable from the button to the LED, without having to refer to any PLC data.

Internal variables must be defined with a name and a data type. The following data types are
available:

Internal variables can be local or global: 

! Local variables are created when the screen is displayed, and destroyed when the screen
is replaced by another, in the case of a multiple page application. 

! Global variables are created when the first screen is created, and are kept alive during the
time the applet runs in the Internet browser. The value of a global variable is not affected
by the applet when the active screen changes. 

BOOL Bit value.
SINT Short signed integer on 8 bits.
DINT Long signed integer on 32 bits.
REAL Single precision floating value on 32 bits.
TIME Time value (less than 24 hours).
STRING Character strings with variable length (maximum length is 255 

characters).
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System Variables

The following variables are available from the "System" origin. They contain useful diagnostic
information about possible errors detected by the applet or the data server.

Note: When the System origin is selected in the tree, the  button is not available.

SYS STRING Global error report. 
SYS_APPLET STRING Error detected by the applet. 
SYS_VARIABLE STRING Communication error detected by the embedded Data 

Server and related to a variable (for example the 
variable cannot be read in PLC). 

SYS_PLC STRING Communication error detected by the embedded Data 
Server and related to one PLC (typically there is a 
communication problem between Data Server and 
PLC). 

SYS_DATA_SERVER STRING Error reported by the embedded Data Server about its 
own behavior (overload, memory low...).
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Customizing the HTML Template
The HTML template defines the size of the screens displayed in a container (HTML page) as
well as the look of the container displaying them. The default template sets containers to the
same size as the screens they display. You can choose to resize the screens for a container. You
can also choose to use a different template for a container.

To resize screens in a container

1. In the project browser, select the container holding the screens to resize, then right-click.

2. From the contextual menu, choose Properties.

The Image Attributes dialog appears.

3. In the width and height fields, enter the new dimensions and click OK.

All existing and new pages for the container will have the new dimensions.

To use another HTML template for a container

1. In the project browser, select the container to use the new template, then right-click.

2. From the contextual menu, choose Properties.

The Image Attributes dialog appears.

3. In the HTML Template field, enter the location of the template to use and click OK.
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Using Multiple Variable Selectors
You can associate a set of specific variables, called Labels, to a specific set of PLC variables
or constants. You associate these labels in the Multiple Variable Selectors (MVS) window. 

The Multiple Variable Selector consists of a list of labels and a list of variable configurations
that you can associate. Using the selector, you choose a particular configuration. For example,
you can have a generic WEB page for a factory assembly line and switch between different sets
of variables used to animate the screen. You could also have a configuration for a factory in
France and another for a similar factory in Germany. The basic variables and objects remain
the same, only their values change.

Example

The example below shows how the properties of a graphic object (a gauge here) can be
associated to a Label in a Multiple Variable Selector. For this example, the height of the red
part of the gauge varies according to the numeric value of the Tank_Level label. The Selector
has a value of 2, therefore, Tank_Level is associated with the PLC variable Tank_Volume.
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Editing Multiple Variable Selectors

You edit multiple variable selectors in the Multiple Variable Selectors editor.

The Multiple Variable Selector editor consists of two parts, the list of available selectors, to the
left, and the grid, to the right, where you enter the labels and variables or constants for the
selector�s configuration.

The selectors appearing in the list are those defined for the current document. You can perform
the following management tasks for selectors:

! create selectors

! delete selectors

! save the contents of selectors

You can also choose to hide or display the selectors list.

In the grid area, you can perform the following management tasks relating to the labels and
variables associated with a selector:

! add columns

! add rows

! append columns

! delete 

To access the Multiple Variable Selectors editor

" From the Tools menu, choose Multiple Variable Selectors.
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Creating Selectors

When creating selectors, you need to insert at least one column and one row in the grid.

To create a selector

1. From the Tools menu, choose Multiple Variable Selectors.

The Multiple Variable Selectors window appears.

2. In the toolbar, click .

A book appears in the list of selectors.

3. Give the book a meaningful name.

Deleting Selectors

To delete a selector

1. From the Tools menu, choose Multiple Variable Selectors.

The Multiple Variable Selectors window appears.

2. From the list of available selectors, select one to remove.

3. In the toolbar, click .

The selector is removed from the list.
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Saving the Contents of a Selector

You can save changes made to a currently selected selector.

To save the contents of a selector

" In the toolbar, click .

Hiding or Displaying the Selectors List

You can choose to hide or display the selectors list when using the Multiple Variable Selector
editor. 

To hide or display the selectors list

" In the toolbar, click .

Adding and Inserting Columns

You can add columns after existing columns. You can also choose to insert columns between
existing ones.

To add columns to the grid area

1. From the toolbar above the grid area, click .

The Add a Column dialog box appears. 

2. Enter an index number and name to appear in the column label, then click OK.
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To insert columns

1. In the grid area, select the column to follow the new one.

2. From the toolbar above the grid area, click .

3. From the menu options, choose Insert Column.

The Add a Column dialog box appears. 

4. Enter an index number and name to appear in the column label, then click OK.

Adding Rows

When adding rows, you need to define the label for the row. Cells will automatically appear
for all existing columns.

To add rows to the grid area

1. From the toolbar above the grid area, click .

The Select Variable editor appears.

2. Enter the information to appear for the row label, then click OK.
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Associating Labels with Objects

You can associate labels created for multiple variable selectors with objects in animated
documents.

To associate a label with an object in an animated document

1. In the workspace, double-click the object.

The Properties window for the object appears.

2. Select a variable then press change.

The Variable window appears.

3. In the browser, to the right, double-click Selectors.

The available multiple variable selectors appear in the tree-like hierarchy.

4. In the browser, select the desired selector.

5. From the list of available labels, to the right of the browser, select a label.

6. Click OK.
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Using the Graphic Objects Library
You can reuse individual objects or groups of objects between documents by sending objects
to the library. You can also create hyper-objects to send to the library. 

The library holds these objects in individual HAD files in the \LIB folder.

The Library window is divided into a browser and a viewing area. The browser displays the
folders and files contained in the library. The viewing area displays the contents of the file
selected in the browser.

When the Library window is active, you can access the options for the Library menu.

To access the library

" From the Library menu, choose Open Library.
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Sending Objects to the Library

Before sending objects to the library, you need to open the library and create a library file to
which to send the object.

To send an object to the library

1. From the Library menu, choose Open.

The Library window appears.

2. In the library browser, select the folder in which to place the library file.

3. From the File menu, choose New.

4. In the New Library dialog box, choose the File option and enter a name for the file, then
click OK.

5. From the Window menu, switch to the animated document holding the object to send.

6. From the Library menu, choose Send to Library.

The object is imported in the library file.

When the animated document and Library window are visible in the workspace, you can also
send an object to the library by holding the Ctrl key depressed then dragging the object from
the animated document to the library�s viewing area.
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Inserting Objects from the Library

Before inserting objects from the library, you need to open the library.

To insert an object from the library

1. From the Library menu, choose Open.

The Library window appears.

2. In the library browser, select the library file holding the object to insert.

The contents of the library file appear in the library window�s viewing area.

3. In the viewing area, select then right-click the object.

4. From the contextual menu, choose Copy.

5. In the animated document, click where you want to insert the object.

6. Right-click, then from the contextual menu choose Paste.

When the animated document and Library window are visible in the workspace, you can also
insert an object by holding the Ctrl key depressed then dragging the object from the library�s
viewing area to the animated document.
98 HiBeam 1.21- Screen Builder



Creating Hyper-Objects

A hyper-object is a group of objects, having a customized property sheet. You customize the
property sheet of a hyper-object in order to hide some fixed properties in the grouped objects
and to assign original names to useful properties. You typically send hyper-objects to the
library for reuse throughout documents.

A hyper-object is a group of objects. The grouped objects have original properties (Styles,
Animation variables, and Effects). The group also has its own properties (Effects).

A public property is a property that can be accessed when an object becomes part of a group.
You can specify which properties to make public for these individual objects. You define
which properties of a selected object are visible in the group�s property sheet in the Public
Properties editor for the object by choosing Public Properties from the Edit menu.
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The properties checked in an object�s Public Properties editor are visible in the group�s
property sheet. You can also enter an alias for the property in order to give it an original name
within the group property sheet and a wished position in the property sheet of the group.

You can lock the properties of an object, i.e., deny direct modification of an its properties;
allow only modifications from the group�s property sheet.

To lock an object�s properties

You can only lock the properties of objects belonging to a group.

1. In the workspace, select the object.

2. From the Edit menu, choose Lock Properties.
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Viewing Screens
You can view screens on any platform running a Java technology-enabled browser, i.e.,
Internet Explorer, Netscape. You view the screens by entering the IP address of the node where
the screen is located and its name (HTML) in the browser. You can also create a default screen
that automatically opens when only the IP address of the node is entered in the browser.

To view a screen using Internet Explorer

The computer on which you view screens must have a TCP/IP connection to the node where
the data server runs and the screen was downloaded.

1. Start a Java-technology enabled browser.

2. In the Address field, enter the following line:
http://IP_address_of_target_node/screen_name.html

3. Click OK.

The screen appears in the browser.
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Linking Screens
You can build a multiple page application by linking screens belonging to the same container
(HTML page). To create such an application, in a container, you build individual screens then
link them together using special animated parts. The Screen Builder environment enables you
to edit many screens at the same time in the workspace. You create links between the screens
using Push Button objects:

A button having the Action Kind style set to Other page (HAD). When the 
operator presses it, the animated area is replaced by the other document. This 
type of button can hold text and can be used to create an association of several 
screens with browsing capabilities within the same application. The connection 
to the data server remains when the visible screen changes due to such a link.
A button having the Action Kind style set to Other WEB document (HTML), 
establishing a link with another WEB page. When the operator activates such a 
link, the animation of the current screen stops and the other WEB page replaces 
the screen in the WEB browser.
102 HiBeam 1.21- Screen Builder



Compiling and Loading Documents
You need to compile animated documents into HTML pages then send them to a web server
where they can be viewed in a browser, connected to a data server providing real-time data.
The compiler performs three tasks:

! checks all references to PLC data

! checks links to other documents

! builds an HTML page, when no errors are detected

You can view compilation messages in the Output window.

To compile an animated document

" From the Main toolbar, click .

OR

" From the Project menu, choose Compile

To send an HTML page to a web server

1. Do one of the following steps:

# From the Main toolbar, click .

# From the Project menu, choose Send to Server.

The Download-Send to Server window appears.

2. In the FTP section, enter the IP address of the web server and a password (if applicable).

3. Click Load.
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Copyright
Information in these pages is subject to change without notice and does not represent a
commitment on the part of ICS Triplex ISaGRAF Inc.. No part of these pages may be
reproduced in any form or by any means, electronic or mechanical, for any purpose without the
express written permission of ICS Triplex ISaGRAF Inc.. 

© 2001-2004 ICS Triplex ISaGRAF Inc.. All rights reserved.

Product or company names included in these pages are trademarks or registered trademarks of
their respective holders.

All logos and links used in this guide are, to the best of our knowledge, included with the
permission of the owner - if this is not the case, please let us know immediately.
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